use strict;
my $str = 'Content-Transfer-Encoding: 7bit
Scheduled job console-context --evs 1 quota list --verbose FIRST_FS produced the following output:
Type : Explicit
Target : ViVol: VOL_ABC
Usage : 100 GB
Limit : 500 GB (Hard)
Last modified : 2010-12-19 04:56:50.834383000+00:00
Type : Explicit
Target : ViVol: VOL_XYZ
Usage : 609 GB
Limit : 3 TB (Hard)
Last modified : 2010-12-21 04:04:23.757073000+00:00
Type : Explicit
Target : ViVol: VOL_123
Usage : 609 GB
Limit : 3 TB (Hard)
Last modified : 2010-12-21 04:04:23.757073000+00:00';
my $regex = qr/(?<line>[^\)]+\)\n\N+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}