import re
regex = re.compile(r"(?<line>[^\)]+\)\n\N+)", flags=re.MULTILINE)
test_str = ("Content-Transfer-Encoding: 7bit\n"
" Scheduled job console-context --evs 1 quota list --verbose FIRST_FS produced the following output:\n"
" Type : Explicit\n"
" Target : ViVol: VOL_ABC\n"
" Usage : 100 GB\n"
" Limit : 500 GB (Hard)\n"
" Last modified : 2010-12-19 04:56:50.834383000+00:00\n"
" Type : Explicit\n"
" Target : ViVol: VOL_XYZ\n"
" Usage : 609 GB\n"
" Limit : 3 TB (Hard)\n"
" Last modified : 2010-12-21 04:04:23.757073000+00:00\n"
" Type : Explicit\n"
" Target : ViVol: VOL_123\n"
" Usage : 609 GB\n"
" Limit : 3 TB (Hard)\n"
" Last modified : 2010-12-21 04:04:23.757073000+00:00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")