$re = '/(title=)"[^"]*" (.*)name="([^"]*)"/m';
$str = 'title="alpha" lorem ipsum lorem ipsum name="beta"
title="omega" Morbi posuere metus purus name="delta"';
$subst = "$1\"$3\" $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;