import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<time>\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2},\\d{0,3}) (?P<message>fail2ban.*(?P<gid>\\[\\d*\\]: )(?P<level>[A-Z]{4,7}) .*)";
final String string = "2020-05-11 06:25:02,732 fail2ban.server [879]: INFO rollover performed on /var/log/fail2ban.log\n"
+ "2020-05-08 01:34:33,079 fail2ban.filter [16566]: INFO [sshd] Found 1.1.1.1 - 2020-05-08 01:34:33\n"
+ "2020-05-09 04:02:31,316 fail2ban.actions [16566]: NOTICE [sshd] Ban 1.0.0.1\n"
+ "2020-05-23 00:09:06,355 fail2ban.server [9474]: INFO Reload jail GHOST\n"
+ "2020-05-23 00:09:06,355 fail2ban.filter [9474]: INFO Removed logfile: '/opt/logs/ghost/https___nonsense_fyi_production.log'\n"
+ "2020-05-23 00:09:07,902 fail2ban.actions [9474]: NOTICE [GHOST] Flush ticket(s) with iptables-multiport\n"
+ "2020-05-23 00:09:07,902 fail2ban.actions [9474]: NOTICE [GHOST] Flush ticket(s) with iptables-allports\n"
+ "2020-05-23 00:09:09,699 fail2ban.jail [9474]: INFO Jail 'GHOST' stopped\n"
+ "2020-05-23 00:09:09,701 fail2ban.jail [9474]: INFO Creating new jail 'GHOST'\n"
+ "2020-05-23 00:09:09,701 fail2ban.jail [9474]: INFO Jail 'GHOST' uses pyinotify {}\n"
+ "2020-05-23 00:09:09,706 fail2ban.jail [9474]: INFO Initiated 'pyinotify' backend\n"
+ "2020-05-23 00:09:09,709 fail2ban.filter [9474]: INFO Added logfile: '/opt/logs/ghost/https___nonsense_fyi_production.log' (pos = 14909, hash = 7091b34995f750999f6c605cd6250439a2e0cde7)\n"
+ "2020-05-23 00:09:09,710 fail2ban.filter [9474]: INFO encoding: UTF-8\n"
+ "2020-05-23 00:09:09,711 fail2ban.filter [9474]: INFO maxRetry: 5\n"
+ "2020-05-23 00:09:09,711 fail2ban.filter [9474]: INFO findtime: 300\n"
+ "2020-05-23 00:09:09,712 fail2ban.actions [9474]: INFO banTime: 2592000\n"
+ "2020-05-23 00:09:09,714 fail2ban.jail [9474]: INFO Jail 'GHOST' started\n"
+ "2020-05-23 00:09:09,714 fail2ban.server [9474]: INFO Reload finished.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}