import Foundation
let pattern = #"(?P<time>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{0,3}) (?P<message>fail2ban.*(?P<gid>\[\d*\]: )(?P<level>[A-Z]{4,7}) .*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2020-05-11 06:25:02,732 fail2ban.server [879]: INFO rollover performed on /var/log/fail2ban.log
2020-05-08 01:34:33,079 fail2ban.filter [16566]: INFO [sshd] Found 1.1.1.1 - 2020-05-08 01:34:33
2020-05-09 04:02:31,316 fail2ban.actions [16566]: NOTICE [sshd] Ban 1.0.0.1
2020-05-23 00:09:06,355 fail2ban.server [9474]: INFO Reload jail GHOST
2020-05-23 00:09:06,355 fail2ban.filter [9474]: INFO Removed logfile: '/opt/logs/ghost/https___nonsense_fyi_production.log'
2020-05-23 00:09:07,902 fail2ban.actions [9474]: NOTICE [GHOST] Flush ticket(s) with iptables-multiport
2020-05-23 00:09:07,902 fail2ban.actions [9474]: NOTICE [GHOST] Flush ticket(s) with iptables-allports
2020-05-23 00:09:09,699 fail2ban.jail [9474]: INFO Jail 'GHOST' stopped
2020-05-23 00:09:09,701 fail2ban.jail [9474]: INFO Creating new jail 'GHOST'
2020-05-23 00:09:09,701 fail2ban.jail [9474]: INFO Jail 'GHOST' uses pyinotify {}
2020-05-23 00:09:09,706 fail2ban.jail [9474]: INFO Initiated 'pyinotify' backend
2020-05-23 00:09:09,709 fail2ban.filter [9474]: INFO Added logfile: '/opt/logs/ghost/https___nonsense_fyi_production.log' (pos = 14909, hash = 7091b34995f750999f6c605cd6250439a2e0cde7)
2020-05-23 00:09:09,710 fail2ban.filter [9474]: INFO encoding: UTF-8
2020-05-23 00:09:09,711 fail2ban.filter [9474]: INFO maxRetry: 5
2020-05-23 00:09:09,711 fail2ban.filter [9474]: INFO findtime: 300
2020-05-23 00:09:09,712 fail2ban.actions [9474]: INFO banTime: 2592000
2020-05-23 00:09:09,714 fail2ban.jail [9474]: INFO Jail 'GHOST' started
2020-05-23 00:09:09,714 fail2ban.server [9474]: INFO Reload finished.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)