# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{(?:[A-Za-z_][A-Za-z_0-9]*|[+\-*\/%<=>&|()0-9. ])*}/hello/g;t' <<< "// \%def{ Value3 , name.len + (i * Person.age) + ( }
// %if{ (name.len == 20) && (value == 20) }"