package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{(?:[A-Za-z_][A-Za-z_0-9]*|[+\-*/%<=>&|()0-9. ])*}`)
var str = `// \%def{ Value3 , name.len + (i * Person.age) + ( }
// %if{ (name.len == 20) && (value == 20) }`
var substitution = "hello"
fmt.Println(re.ReplaceAllString(str, substitution))
}