$re = '/([^.()]+)(?:\(([^.()]+)\))?(?:\.(gt|ge|lt|le|eq|bt|in|ct|no)(.*))?/';
$str = 's_dsd.no342';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);