$re = '/(?si)<a[^>]+href="(?P<href>[^>"]+)"/';
$str = '<a href="http://google.com">hello</a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);