import re
regex = re.compile(r"(assertTrue)(.+?)( ==)")
test_str = (" $this->assertTrue($post->item_id == $actionItem->id);\n"
" $this->assertTrue($post->action == 'edited');\n"
" $this->assertTrue($post->type == 'Action Item');\n"
" $this->assertTrue($post->title == $actionItem->title);\n\n"
"Designed for use in PHPstorm. REGEX in First \"Replace\" string, and the following in the second:\n"
"AssertEquals$2,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")