#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?=\.).+@"
Local $sString = "abc.ned@hd.com" & @CRLF & _
"asdasd@nd"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)