const regex = /<p>(\s| |<\/?\s?br\s?\/?>)*<\/?p>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p>(\\s| |<\\\/?\\s?br\\s?\\\/?>)*<\\\/?p>', 'gi')
const str = `<div class="copy_box"><p></p>
<p class="keepme">Nam blandit orci vel lorem rhoncus, eu ornare mauris tempor. Cras et volutpat est, eget tempus lectus. In placerat felis a convallis dapibus.</p>
<p class="keepme">Aliquam viverra auctor mollis. Aliquam ornare urna non nisl cursus laoreet. Fusce sed eleifend turpis, pretium lectus. Proin eleifend scelerisque lacus id eleifend. Aenean luctus est et tristique convallis. In blandit urna.</p>
<p>
</p></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}