re = /<p>(\s| |<\/?\s?br\s?\/?>)*<\/?p>/i
str = '<div class="copy_box"><p></p>
<p class="keepme">Nam blandit orci vel lorem rhoncus, eu ornare mauris tempor. Cras et volutpat est, eget tempus lectus. In placerat felis a convallis dapibus.</p>
<p class="keepme">Aliquam viverra auctor mollis. Aliquam ornare urna non nisl cursus laoreet. Fusce sed eleifend turpis, pretium lectus. Proin eleifend scelerisque lacus id eleifend. Aenean luctus est et tristique convallis. In blandit urna.</p>
<p>
</p></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end