// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<p>(\s| |<\/?\s?br\s?\/?>)*<\/?p>").unwrap();
let string = "<div class=\"copy_box\"><p></p>
<p class=\"keepme\">Nam blandit orci vel lorem rhoncus, eu ornare mauris tempor. Cras et volutpat est, eget tempus lectus. In placerat felis a convallis dapibus.</p>
<p class=\"keepme\">Aliquam viverra auctor mollis. Aliquam ornare urna non nisl cursus laoreet. Fusce sed eleifend turpis, pretium lectus. Proin eleifend scelerisque lacus id eleifend. Aenean luctus est et tristique convallis. In blandit urna.</p>
<p>
</p></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}