#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "dc\Dc(?P<name1>\d+)\D"
Local $sString = "column row 1" & @CRLF & _
"dc(ID) 273" & @CRLF & _
"dc(SBC) 2" & @CRLF & _
"dc(TGID) 273" & @CRLF & _
"dc(TGN) 434" & @CRLF & _
"dc(beginTime) 2" & @CRLF & _
"dc(c1907466966) 29" & @CRLF & _
"dc(c1907466967) 38" & @CRLF & _
"dc(c1907466968) 32" & @CRLF & _
"dc(c1907466969) 15" & @CRLF & _
"dc(c1907466970) 32" & @CRLF & _
"dc(c1907466971) 34" & @CRLF & _
"dc(c1907466972) 5" & @CRLF & _
"dc(c1907466973) 28" & @CRLF & _
"dc(c1907466974) 36" & @CRLF & _
"dc(c1907466975) 33" & @CRLF & _
"dc(c1907466976) 38" & @CRLF & _
"dc(c1907466977)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(?P<subname>\w+_(?<=_).*?(?=\.)).*" |"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")