use strict;
my $str = 'column row 1
dc(ID) 273
dc(SBC) 2
dc(TGID) 273
dc(TGN) 434
dc(beginTime) 2
dc(c1907466966) 29
dc(c1907466967) 38
dc(c1907466968) 32
dc(c1907466969) 15
dc(c1907466970) 32
dc(c1907466971) 34
dc(c1907466972) 5
dc(c1907466973) 28
dc(c1907466974) 36
dc(c1907466975) 33
dc(c1907466976) 38
dc(c1907466977)
(?P<subname>\\w+_(?<=_).*?(?=\\.)).*" |';
my $regex = qr/dc\Dc(?P<name1>\d+)\D/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}