using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:\d+%(?: |for)+([A-Z](?:[\w\.♀♂']|(?: (?=[A-Z])))+))+)[, &]*";
string input = @"95% for Pikachu, 92% for Mr. Mime
70% for Paras & 100% Arcanine
99% Diglett, 40% Dugtrio
10% Squirtle, 100% for Alakazam
30% Metopod & 99% Nidoran♂";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}