re = /(?:(?:\d+%(?: |for)+([A-Z](?:[\w\.♀♂']|(?: (?=[A-Z])))+))+)[, &]*/m
str = '95% for Pikachu, 92% for Mr. Mime
70% for Paras & 100% Arcanine
99% Diglett, 40% Dugtrio
10% Squirtle, 100% for Alakazam
30% Metopod & 99% Nidoran♂'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end