#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(SHOW:.*?)\s+\d{1,2}:\d{1,2}\s+[AP]M\b"
Local $sString = "SHOW: Game of Thrones 7:00 PM EST" & @CRLF & _
"SHOW: The Outsider 3:00 PM EST" & @CRLF & _
"SHOW: Don't Be a Menace to South Central While Drinking Your Juice In The Hood 10:00 AM EST"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")