$re = '/^[A-Z]{6}[A-Z0-9]{2}([A-Z0-9]{3})?$/';
$str = 'DEUTDEFF500';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);