package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\{\{\s*[Cc]oord\s*(?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?)\|\s*name\s*=[^\|\{\}]*((?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?\}\})`)
var str = `1. {{Coord|a=b|name=foo}}
2. {{coord|name=foo|a=b}}
3. {{ Coord
| name = foo
| a = b }}
4. {{coord|name=foo|a={{b}}}}
5. {{coord|a={{b}}|name=foo}}
6. {{coord|a={{b|{{c}}}}|name=foo}} <!-- fails -->
5. {{coord|a=b|name={{foo}}}} <!-- fails -->
`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}