# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\{\{\s*[Cc]oord\s*(?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?)\|\s*name\s*=[^\|\{\}]*((?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?\}\})"
test_str = ("1. {{Coord|a=b|name=foo}}\n"
"2. {{coord|name=foo|a=b}}\n"
"3. {{ Coord\n"
"| name = foo\n"
"| a = b }}\n"
"4. {{coord|name=foo|a={{b}}}}\n"
"5. {{coord|a={{b}}|name=foo}}\n"
"6. {{coord|a={{b|{{c}}}}|name=foo}} <!-- fails -->\n"
"5. {{coord|a=b|name={{foo}}}} <!-- fails -->\n")
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.