// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\{\{\s*[Cc]oord\s*(?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?)\|\s*name\s*=[^\|\{\}]*((?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?\}\})").unwrap();
let string = "1. {{Coord|a=b|name=foo}}
2. {{coord|name=foo|a=b}}
3. {{ Coord
| name = foo
| a = b }}
4. {{coord|name=foo|a={{b}}}}
5. {{coord|a={{b}}|name=foo}}
6. {{coord|a={{b|{{c}}}}|name=foo}} <!-- fails -->
5. {{coord|a=b|name={{foo}}}} <!-- fails -->
";
let substitution = "\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}