#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)\biPhone:\n\n+(?:(?!\n\n).)+\bSerial Number: (\w+)"
Local $sString = "USB:" & @CRLF & _
"" & @CRLF & _
"USB 2.0 SuperSpeed Bus:" & @CRLF & _
"" & @CRLF & _
" Host Controller Location: Built-in USB" & @CRLF & _
"" & @CRLF & _
" Internal Memory Card Reader:" & @CRLF & _
"" & @CRLF & _
" Product ID: 0x8406" & @CRLF & _
" Serial Number: 000000000820 //i dont want this" & @CRLF & _
" Built-In: Yes" & @CRLF & _
"" & @CRLF & _
"USB 3.0 Hi-Speed Bus:" & @CRLF & _
"" & @CRLF & _
" PCI Device ID: 0x8c31 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" iPhone:" & @CRLF & _
"" & @CRLF & _
" Vendor ID: 0x05ac (Apple Inc.)" & @CRLF & _
" Version: 7.02" & @CRLF & _
" Serial Number: wea0aa752ada7722ac92575e98z2e89c691f4282 //i want this" & @CRLF & _
" Speed: Up to 480 Mb/sec" & @CRLF & _
" Manufacturer: Apple Inc." & @CRLF & _
" Location ID: 0x14100000 / 9" & @CRLF & _
"" & @CRLF & _
" Apple Internal Keyboard / Trackpad:" & @CRLF & _
"" & @CRLF & _
" Product ID: 0x0262" & @CRLF & _
" Vendor ID: 0x05ac (Apple Inc.)" & @CRLF & _
" Location ID: 0x14c00000 / 3" & @CRLF & _
" Current Available (mA): 500" & @CRLF & _
" Current Required (mA): 40" & @CRLF & _
" Built-In: Yes"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")