re = /(?s)(?:isaac.*)(select)/m
str = 'aisaacbcdefgisaachijklmnopqrstuvwxyz
abcdefgselecthijklmno'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end