import Foundation
let pattern = #"(?<=\\)[\d]{6}[^\\]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"str1 = <C:\User\Test\xyz\022014-101\more\stuff\022014\1>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}