using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*Copyright . \d{4} b?y? ?(.*)\.";
string input = @"</p><div class=""copyright"">Copyright © 2005 Candy Arrington. Used by permission. All rights reserved.</div>
<div id=""nextPrev"">
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}