package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*Copyright . \d{4} b?y? ?(.*)\.`)
var str = `</p><div class="copyright">Copyright © 2005 Candy Arrington. Used by permission. All rights reserved.</div>
<div id="nextPrev">
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}