import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*Copyright . \\d{4} b?y? ?(.*)\\.";
final String string = "</p><div class=\"copyright\">Copyright © 2005 Candy Arrington. Used by permission. All rights reserved.</div>\n"
+ " <div id=\"nextPrev\">\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}