const regex = /.*Copyright . \d{4} b?y? ?(.*)\./;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*Copyright . \\d{4} b?y? ?(.*)\\.', '')
const str = `</p><div class="copyright">Copyright © 2005 Candy Arrington. Used by permission. All rights reserved.</div>
<div id="nextPrev">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}