re = /.*Copyright . \d{4} b?y? ?(.*)\./
str = '</p><div class="copyright">Copyright © 2005 Candy Arrington. Used by permission. All rights reserved.</div>
<div id="nextPrev">
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end