// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*Copyright . \d{4} b?y? ?(.*)\.").unwrap();
let string = "</p><div class=\"copyright\">Copyright © 2005 Candy Arrington. Used by permission. All rights reserved.</div>
<div id=\"nextPrev\">
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}