// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{4}\w{4}\.\d{1,3})").unwrap();
let string = " 1710ABCD.131711ABCD.431711ABCD.41711ABCD.4041711ABCD.25";
let substitution = "\\1,";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}