use strict;
my $str = ' 1710ABCD.131711ABCD.431711ABCD.41711ABCD.4041711ABCD.25';
my $regex = qr/(\d{4}\w{4}\.\d{1,3})(?=\d{4}|$)/p;
my $subst = '\\1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";