#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(?:a|c|bc)+$)"
Local $sString = "abc" & @CRLF & _
"" & @CRLF & _
"acb" & @CRLF & _
"" & @CRLF & _
"ccbc" & @CRLF & _
"" & @CRLF & _
"bac" & @CRLF & _
"" & @CRLF & _
"bca" & @CRLF & _
"" & @CRLF & _
"aaa" & @CRLF & _
"" & @CRLF & _
"cab" & @CRLF & _
"" & @CRLF & _
"cba" & @CRLF & _
"" & @CRLF & _
"cabcabcbacbcaaaccbbaaccacbac"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")