$re = '/tooltext=(.*?\\\\&)*.*?&/im';
$str = '\'&label=20:01:27&tooltext=abc\\&|\\|cba&value=6|59|58|89&color=ff0000|00ffff\'
\'&label=20:01:27&tooltext=abc\\&|\\|cba&value=6|59|58|89\'
\'&label=20:01:27&tooltext=abc&|\\|cba&value=6|59|58|89\'
\'&label=20:01:27&tooltext=abc\\&\\as&\\&dsa\\&|\\|cba&value=6|59|58|89\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);