import re
regex = re.compile(r"(?<!\")((?>[\w- ]+))(?!\")")
test_str = "000000,\"NAMPUNG-NI 66 KV TAP SONGCHO\"ON\","
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)