using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[A-Za-z]{1,4}|[A-Za-z]{4}\d+)$";
string input = @"crow1111111111
crowe111111111
cro
crow
c1111111
111111crow";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}