package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^\\|]|\\[\s\S])+`)
var str = `fielda|field b |field\|with\|pipe\|inside`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}