const regex = /^(?:(?:[a-f0-9]*)?:){1,7}[a-f0-9]*$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[a-f0-9]*)?:){1,7}[a-f0-9]*$', 'igm')
const str = `2001:db8:3333:4444:5555:6666:7777:8888
2001:db8:3333:4444:CCCC:DDDD:EEEE:FFFF
::
2001:db8::
::1234:5678
2001:db8::1234:5678
2001:0db8:0001:0000:0000:0ab9:C0A8:0102
2001:db8:1::ab9:C0A8:102
::1
asdlkjkjd:asldjlaskdjlkja:lasdkjlkajsd:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}