# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:[a-f0-9]*)?:){1,7}[a-f0-9]*$"
test_str = ("2001:db8:3333:4444:5555:6666:7777:8888\n"
"2001:db8:3333:4444:CCCC:DDDD:EEEE:FFFF\n"
"::\n"
"2001:db8::\n"
"::1234:5678\n"
"2001:db8::1234:5678\n"
"2001:0db8:0001:0000:0000:0ab9:C0A8:0102\n"
"2001:db8:1::ab9:C0A8:102\n"
"::1\n\n"
"asdlkjkjd:asldjlaskdjlkja:lasdkjlkajsd:")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.