$re = '/^(([0-1][0-9])|([2][0-3])):([0-5][0-9])(:([0-5][0-9]))?([.]\d{3})?$/m';
$str = '23:59
23:59:30
23:59:34.123
23:59:12
23:60
23:59.
23:59.60';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;