#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?=.*[A-Z])" & @CRLF & _
"(?=.*[a-z])" & @CRLF & _
"(?=.*[0-9])" & @CRLF & _
"(?!.*[<>`])" & @CRLF & _
"(?=[^.,:;'!@#$%^&*_+=|(){}[?\-\]\/\\]*" & @CRLF & _
" [.,:;'!@#$%^&*_+=|(){}[?\-\]\/\\]" & @CRLF & _
" [^.,:;'!@#$%^&*_+=|(){}[?\-\]\/\\]*$" & @CRLF & _
")" & @CRLF & _
".{8}$"
Local $sString = "Aa1;;aaa" & @CRLF & _
"1aD15fs!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")