using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*[A-Z])
(?=.*[a-z])
(?=.*[0-9])
(?!.*[<>`])
(?=[^.,:;'!@#$%^&*_+=|(){}[?\-\]\/\\]*
[.,:;'!@#$%^&*_+=|(){}[?\-\]\/\\]
[^.,:;'!@#$%^&*_+=|(){}[?\-\]\/\\]*$
)
.{8}$";
string input = @"Aa1;;aaa
1aD15fs!";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}