# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)\bflirt[\wá-ú]+"
test_str = ("Palabras que empiezan con flirte 13 letras:\n"
"flirtearÃamos,\n"
"Palabras que empiezan con flirte 12 letras:\n"
"flirteasteis, flirtearemos, flirteáramos, flirteábamos, flirteáremos, flirteásemos, flirtearÃais,\n"
"Palabras que empiezan con flirte 11 letras:\n"
"flirtearÃan, flirtearéis, flirtearÃas, flirteareis, flirteaseis, flirtearais, flirteabais,\n"
"Palabras que empiezan con flirte 10 letras:\n"
"flirteemos, flirtearán, flirtearás, flirteases, flirteados, flirtearÃa, flirteabas, flirteaban, flirteasen, flirteaste, flirtearse, flirtearan, flirtearas, flirteando, flirteamos, flirtearen, flirteares, flirtearon, flirteadas,\n"
"Palabras que empiezan con flirte 9 letras:\n"
"flirteáis, flirteéis, flirteara, flirtease, flirteado, flirteada, flirteaba, flirteare, flirteará, flirtearé:\n"
"Palabras que empiezan con flirte 8 letras:\n"
"flirteas, flirtean, flirtear, flirteos, flirtead, flirtees, flirteen,\n"
"Palabras que empiezan con flirte 7 letras:\n"
"flirteé, flirteo, flirtea, flirtee, flirteó,")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.