$re = '/[^\x00-\x7F]+/';
$str = 'asdİöddsadfçğsdsl.xxiczixcIldsskamsdkas.m,./,m,,ççç';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);