using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?:EN|DE|FR)\s+(?:ISO|DIN)|(?:ISO|DIN)\s+(?:EN|DE|FR))\s+\d+[-:]\d+";
string input = @"FR ISO 23213:2020 or DIN EN 2323-2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}