re = /^data:.+\/(.+);base64,(.*)$/
str = 'data:image/jpeg;base64,/9j/4AAQSkZJRgABAgEASABIAAD/7QAsUGhvd'
# Print the match result
str.match(re) do |match|
puts match.to_s
end