$re = '/-(?=\d+$)/m';
$str = 'this-is-a-boy-5
this23-is-a-boy-10
this-41';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);