const regex = /(?:[-_]?[0-9]+x[0-9]+)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[-_]?[0-9]+x[0-9]+)+', 'g')
const str = `http://url.com/0304-parapente-lagoon-Reunion-96x64.jpg
http://url.com/0304-parapente-lagoon-Reunion-960x640.jpg
http://url.com/0304-parapente-lagoon-Reunion-1500x1000.jpg
http://url.com/0304-parapente-lagoon-Reunion-1280x840-960x640.jpg
http://url.com/0304-parapente-lagoon-Reunion.jpg
http://url.com/520963918_960x540.jpg`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);